Problém spolupráce Apache 2.2.x a PHP 5.1.x

Dnes som nainštaloval najnovšiu verziu Apache HTTP servera (v2.2.2) a najnovšiu verziu PHP (v5.1.4). Na moje prekvapenie navzájom nechceli spolupracovať, konkrétne Apache odmietal použiť modul php5apache2.dll. Vyhadzovalo to hlášku:
Cannot load C:/php/php5apache2.dll into server: The specified module could not be found.

Nejakú chvíľu som zisťoval, v čom je problém, a nakoniec som sa dozvedel, že spomínaný modul spolupracuje iba s Apache v2.0.x.

Naštastie šikovní ľudia z ApacheLounge pripravili riešenie, kým si PHP Group toto issue dorieši.

Leave a Reply

Your email address will not be published. Required fields are marked *